SharpDevelop Community

Get your problems solved!
Welcome to SharpDevelop Community Sign in | Join | Help
in Search

Browse by Tags

All Tags » UnitTests (RSS)
  • NUnit 2.6.1 Support

    SharpDevelop 4.3 has been updated to use NUnit 2.6.1 which was recently released. The full details on what has changed in NUnit 2.6.1 can be found in the NUnit release notes . One change in this release caused some of SharpDevelop's own unit tests to break so this change is highlighted in the following...
    Posted to Weblog by MattWard on 08-12-2012
  • Unit Testing with IronRuby

    SharpDevelop 4 has been updated to support unit testing with IronRuby. It uses the Ruby testing framework Test::Unit so you will need to have the Ruby standard library on your machine. IronRuby 1.0 targets Ruby 1.8.6 and includes it in its download so one way to get the Ruby standard library is to download...
    Posted to Weblog by MattWard on 07-15-2010
  • Unit Testing with IronPython

    SharpDevelop 4 has been updated to support unit testing with IronPython. First you will need to install Python 2.6 . SharpDevelop uses the standard Python unit test library (unittest.py) to run the unit tests. SharpDevelop should detect where the Python standard library is installed but if it does not...
    Posted to Weblog by MattWard on 06-01-2010
  • Code Sample - Gallio Addin

    In SharpDevelop 4.0 the unit testing addin has been modified so it can be extended to support the use of custom unit test runners. An example addin has been created to show how to integrate a custom unit test runner. In this code sample Gallio has been integrated to provide support for running MbUnit...
    Posted to Weblog by MattWard on 05-31-2010
  • NUnit 2.5 Support

    SharpDevelop 3.1 now supports NUnit 2.5 . A summary of which NUnit version is supported by SharpDevelop is shown in the table below. SharpDevelop 3.1 NUnit 2.5 SharpDevelop 3.0 NUnit 2.4.8 SharpDevelop 2.2.1 NUnit 2.4.7 SharpDevelop 1.1 NUnit 2.2 NUnit 2.5 Changes NUnit 2.5 has changed quite substantially...
    Posted to Weblog by MattWard on 05-10-2009
  • Testing with .NET 1.1 in SharpDevelop 2.1

    SharpDevelop 2.1, as of revision 2135, now allows you to run your unit tests against .NET 1.1 or .NET 2.0. Which framework your tests are run under is determined by the target framework your test project. So if you choose .NET 1.1 as your target framework, your tests are run in the .NET 1.1 framework...
    Posted to Weblog by MattWard on 12-14-2006
  • Unit Testing Changes In SharpDevelop 2.1

    The Unit Tests window in SharpDevelop 2.1 (revision 2039) has been changed in order to fix a few bugs and problems that it had. How you unit test in SharpDevelop is still the same, as explained in the Unit Testing feature tour , but there are some new features shown below. Most of the changes have been...
    Posted to Weblog by MattWard on 11-22-2006
  • UnitTestsWindowSD21

    Posted to Gallery by MattWard on 11-22-2006
Page 1 of 1 (8 items)
Powered by Community Server (Commercial Edition), by Telligent Systems
Don't contact us via this (fleischfalle@alphasierrapapa.com) email address.