SharpDevelop Community

Get your problems solved!
Welcome to SharpDevelop Community Sign in | Join | Help

Search

Page 1 of 2 (12 items) 1 2 Next >
  • Re: GUI not appearing using Run but does from command line -- How to solve

    I tried a simple app like you suggested and it worked! So I agree it must not be the paths---at least not with the references used and paths to program files. I am trying to use a third-party .Net control which I've used extensively in VS (Flexcell) which is a grid control. It may be the offending reference. You gave me an idea. As soon as I ...
    Posted to Using SharpDevelop (Forum) by sbrand on 07-18-2017
  • Re: GUI not appearing using Run but does from command line -- How to solve

    Well if you are confused then I don't feel so bad<G>. I can switch back and forth between coding and designing on the MainForm without any problem. The MainForm.py still contains both the def__init(self) and def InitializeComponent(self). Like I said---during my initial experimentation I was able to double-click the .exe file and was ...
    Posted to Using SharpDevelop (Forum) by sbrand on 07-17-2017
  • GUI not appearing using Run but does from command line -- How to solve

    Hello all. I have a VB.net app (I'm just trying to learn Python) and when I run: ipy Program.py at the command line in the directory for the solution (where Program.py) is located the GUI appears fine. When I click the created .exe file after a Build (with no errors) it does not appear (tho' does appear to be doing something behind the ...
    Posted to Using SharpDevelop (Forum) by sbrand on 07-17-2017
  • Re: trying to print out debugging information

    Thanks for the reply Simon. That makes sense. Still learning....
    Posted to Using SharpDevelop (Forum) by sbrand on 07-16-2017
  • Re: trying to print out debugging information

    Ok...I've helped myself "slightly". When I compile instead to a Console app then error information shows up in the console window so I can refer to that and see where I got tripped up. That has been helpful. Also using MessageBox.Show(str(e)) rather than MessageBox.Show(e) has helped. BUT--Now when I go back to compile as a Windows ...
    Posted to Using SharpDevelop (Forum) by sbrand on 07-12-2017
  • trying to print out debugging information

    My vb.net application was working both from SharpDevelop and clicking on the .exe file. Then it stopped working from the .exe and I'm trying to debug--and at the same time learn how to extend my debugging knowledge to figure out other problems. I have tried: try:     form = ...
    Posted to Using SharpDevelop (Forum) by sbrand on 07-09-2017
  • Where is SQLite DataAdapter?

    Continuing on my struggle to learn IronPython and Sqlite and SharpDevelop.... I can open and query a database by creating a cursor and looping through the returned rows. I want to create a DataAdapter so I can fill a DataSet. I create the DataSet easily as it is not specific to a certain SQL provider. But for the life of me I can locate the ...
    Posted to Using SharpDevelop (Forum) by sbrand on 07-07-2017
  • Re: help with sqlite3

    Thanks Simon--any reply at my stage is better than none <G>. So here is an update. I copied a working VS solution as you suggested. I had to edit the app.confg file  (I think that was the one) to eliminate an error and suprisingly the app opened in SharpDevelop. I did not test it extensively but it did import a .CSV file and populate a ...
    Posted to Using SharpDevelop (Forum) by sbrand on 07-06-2017
  • help with sqlite3

    Hello all. I am trying to translate my experience with SQLite in VS (VB.net) to SharpDevelop so I can use the Forms Designer as I learn Python. When I use ipy.exe I can import sqlite3 and type commands and generate a test database file.   But when I try to do this in code inside my Form I am failing. The screen "blinks" and there ...
    Posted to Using SharpDevelop (Forum) by sbrand on 07-06-2017
  • Re: changing .NET assembly

    Hi Simon Sorry it took so long to get back to you... I tried your suggestion and there was already three lines referencing a .NetFramework version (see below). I changed the three references to a version of a .Net version that was different from the one I specified on creating the new project. When I reloaded the project it reloaded without any ...
    Posted to Using SharpDevelop (Forum) by sbrand on 07-04-2017
Page 1 of 2 (12 items) 1 2 Next >
Powered by Community Server (Commercial Edition), by Telligent Systems
Don't contact us via this (fleischfalle@alphasierrapapa.com) email address.