SharpDevelop Community

Get your problems solved!
Welcome to SharpDevelop Community Sign in | Join | Help
in Search

Language is improperly set

Last post 05-01-2016 5:27 PM by GraveYardOwner. 7 replies.
Page 1 of 1 (8 items)
Sort Posts: Previous Next
  • 04-02-2007 8:13 AM

    Language is improperly set

    I installed SharpDevelop and had a behavior happen that I am not happy with.

    My computer runs a German version of Windows XP Media edition. My software is English. When I installed SharpDevelop, it defaulted to German, which I promptly changed to English. I thought all was ok.

    When I ran Visual Studio my compiler now only spits out German error and warning messages. Could somebody tell me how to switch back to English?

    I have to say I am not impressed that SharpDevelop defaulted to German. Had SharpDevelop read my language and interface settings it would have realized that I am running a German version of Windows XP in Canadian-English mode.

    Thanks

     

  • 04-02-2007 4:09 PM In reply to

    Re: Language is improperly set

    SharpDevelop doesn't change any setting that would affect the compiler in Visual Studio.

    You must have installed a language pack for .NET to get German error messages, i.e. by installing the German .NET SDK.

  • 04-03-2007 2:21 PM In reply to

    Re: Language is improperly set

    No I did not install a language service pack. I almost 100% sure it was a SharpDevelop error because I was developing in Visual Studio and X-Develop before I installed SharpDevelop. Then I installed SharpDevelop and the first thing SharpDevelop did was change into German mode. Then I switched language UI into English exited SharpDevelop and restarted SharpDevelop. I played around with SharpDevelop and exited to get back to my main work. It was at that moment I noticed the errors in Visual Studio and X-Develop were being output in German, and not English. I fixed Visual Stuido, but have not been able to fix X-Develop. So one could deduce it was SharpDevelop that did something in the registries.

    I have never installed the German .NET SDK, nor allowed updating of any German software. All, and I repeat all of my software is English. The reason I have a German OS is because when I bought the computer it had German Windows XP Media Edition and have as of yet not switched (though I will shortly).

     So now comes the question what settings can I set so that I get to see my English messages again.

     

  • 04-03-2007 2:50 PM In reply to

    Re: Language is improperly set

    SharpDevelop does not write to the registry at all. 

    Honestly, I have no idea where the C# compiler stores that setting and why it would remember running in a German environment.

    By the way, SharpDevelop uses the regional settings (the one also used for currency, number format etc.) to determine the initial language to run with, so you still must have those set to German on your computer.

  • 04-05-2007 8:44 PM In reply to

    Re: Language is improperly set

    Well, this is where I wonder... My regional settings are English Canada, and my local settings are Canada, and my keyboard is in English USA. Look at the image at the url http://www.devspace.com/~christianhgross/images/sharpdevelop.jpg. If Sharpdevelop is only reading the regional settings then SharpDevelop should have started in English. But SharpDevelop started in the German language. If you look at the output of the C# compiler in X-Develop IDE it is in German with plenty of errors in the spelling because X-Develop is operating in English Unicode mode. Before I installed SharpDevelop everything including X-Develop was operating in English mode. As a matter of rule I always on installation of Windows XP explicitly set everything to English Canadian so that I do not get accidental language settings.

    But I am not going to pursue this any further. I am going to go out buy Vista in English, and then re-install everything... 

     

  • 10-20-2011 10:14 AM In reply to

    Re: Language is improperly set

    Bringing an ages old thread back to life, anyone has any idea how to get compiler errors in English?

    I am running Windows 7 x64, Finnish version and SharpDevelop in English. I would really prefer to have English compiler errors because Finnish ones do not make any sense to me. Any ideas where could I change the language?

  • 10-24-2011 5:40 PM In reply to

    • siegi44
    • Top 10 Contributor
    • Joined on 03-31-2006
    • Steyr, Austria
    • Posts 806
    • Team Members

    Re: Language is improperly set

    Hi,

    you can change the language by installing the English version of the .NET Framework. There is no way to change the language dynamically.

    regards,

    Siegfried

  • 05-01-2016 5:27 PM In reply to

    Re: Language is improperly set

    I have the same problem. SharpDevelop destroyed my error output. I have now german output of exceptions in the debugger because the system has a german windows version. How do I get back the English Error output again? I also never had any language packs installed?

Page 1 of 1 (8 items)
Powered by Community Server (Commercial Edition), by Telligent Systems
Don't contact us via this (fleischfalle@alphasierrapapa.com) email address.