SharpDevelop Community

Get your problems solved!
Welcome to SharpDevelop Community Sign in | Join | Help
in Search

SharpDevelop/Net Framework question

Last post 08-23-2005 7:22 PM by tmofield. 7 replies.
Page 1 of 1 (8 items)
Sort Posts: Previous Next
  • 08-23-2005 5:33 PM

    SharpDevelop/Net Framework question

    Is it possible to use SharpDevelop with the .NET 1.0.3705 framework?  I know on this site it states that you need the 1.1 SDK, but I was wondering if it would still work with an earlier version, or if there were workarounds. 

    Thanks in advance.

  • 08-23-2005 6:10 PM In reply to

    Re: SharpDevelop/Net Framework question

    It might work when you compile from source code. Honestly, never tried that because FW 1.0 shouldn't be used in production any more.

    Chris

  • 08-23-2005 7:22 PM In reply to

    • tmofield
    • Top 75 Contributor
    • Joined on 08-22-2005
    • Tennessee
    • Posts 53

    Re: SharpDevelop/Net Framework question

    The framework is designed to allow diferent versions to be installed side by side on the same computer.  When a running program needs something from the older version of the framework it will use the old framework version.  It is best to develop using the most recent version of the .net framework released due to many bug fixes.  You have to remember that dotNet is a Microsoft product meaning that earlier versions are full of bugs.  Microsoft historically does not produce a good product the first time around; it usually takes a couple of revisions and service packs to get it right.  If you have a program that targets elements of the old framework, you can make an installer that includes the old framework and install both the program and the old framework at the same time.  If you can cause your program to target the new framework by removing obselete references and using the new ones, you should probably do this.  It will make a more stable release.  Also the framework looks for necessary elements first in the install directory and if it can not find it there, it will check the GAC (Global Assembly Cache). 

     

    UPDATE (Sept 15, 2005):

    The framework versions are backward compatible.  Programs developed by version 1.0 will run on version 1.1 and 2.0.  In theory there is no need to install older versions of the framework.

     

    I hope this helps.  Let us know how you resolved your problem.

     

  • 08-25-2005 2:20 PM In reply to

    Re: SharpDevelop/Net Framework question

    Thanks for the help...

    The problem is that some of our current in-house software is dependent upon the 1.0 version of the .Net framework, and I am also trying to build a highly-customized reporting system that pulls its data from an Oracle 8i data warehouse.  So, I've been trying to look around for older drivers/libraries that would work with the database, as well as with SharpDevelop.  I don't know if there are any 1.1 framework add-ons for Oracle 8i (I'll have to Google for that today when I get the chance).  That's why I was hoping SharpDevelop would run with the older framework, because it would probably be a little easier on my end (even though I should use the later version of the framework).

  • 08-26-2005 8:44 PM In reply to

    Re: SharpDevelop/Net Framework question

    I got it to work.  I installed the 1.1 framework without a hitch, alongside the 1.0 framework. Plus, I got the first few elements of my reporting system up and running in C#.  So far, so good.
  • 08-27-2005 12:22 AM In reply to

    • tmofield
    • Top 75 Contributor
    • Joined on 08-22-2005
    • Tennessee
    • Posts 53

    Re: SharpDevelop/Net Framework question

    Your program WILL work as long as you have the 1.0 framework installed alongside.  If you get lucky you may be able to compile your 1.0 programs against the 1.1 framework without having to change much code.  Just be prepared to do a thourough testing before releasing your old program compiled against the 1.1 framework.  In the long run using the 1.1 version of the framework will make your applications more secure and stable.  Remember that a majority of Microsoft revisions are targeted at security issues. 

    BTW rumor has it that Longhorn/Vistas (MS's new OS)  is going to screw with the .net framework yet some more.

  • 08-31-2005 6:32 PM In reply to

    Re: SharpDevelop/Net Framework question

    I wouldn't doubt it.  Microsoft seems to change frameworks every couple of years (or libraries at least).  I remember trying to learn graphics years ago (not really DirectX per se, just basic drawing on a form with brushes, device contexts, etc) on my own with a Borland compiler and Windows 3.1.  I then went to Windows 98, and then used Borland C++ Builder.  It really didn't help that Borland had their own way of doing things with VCL and OWL libraries (their answer to MFC libraries I think).  The documentation that came with the IDE was incomplete and some of the examples didn't even work right.  It was frustrating enough trying to learn how to program in Windows, and then fight the compiler/IDE on top of it.  Way back, though, I remember seeing "WinG" among other things.  I decided against studying it and a few other things.  I'm sure Vista will mess with the .NET framework some more.  They are not into the maintenance game too much.  They would probably go broke that way, so they keep pushing new products and upgrading all the time.  It gets tiring, but I figure I can put something together fast enough here that will be pretty easy to maintain.  Besides, we just barely upgraded to XP a year or two ago (seriously), so I doubt they are going to spring for Vista anytime within the next 3-4 years.

    As a side note, I also picked up an OpenGL book (the standards book/tutorial) a while back.  Then, I read a few weeks ago that Windows Vista is going to screw with that, too.  As in, force an OpenGl implementation to go through DirectX no matter what as a "bottom layer" so to speak and clobber its performance.  I'm getting really sick of this.

    Thanks again for the help.

  • 08-31-2005 9:05 PM In reply to

    • tmofield
    • Top 75 Contributor
    • Joined on 08-22-2005
    • Tennessee
    • Posts 53

    Re: SharpDevelop/Net Framework question

    Some things I learned recently:

    If your 1.0 program does not use any obselete calls, the 1.1 framework will run it.  I installed a program developed in 1.0 and it works like a charm using only the 1.1 framework.   In theory, dotNet 2.0 is supposed to provide some backward compatibility targeted at versions 1.0 and 1.1, but I am unsure of how it will perform given the fact that Microsoft is still testing user submitted programs and I am unclear what will become obselete until the 2.0 version is released in November.  It may take a couple of service packs to get working properly.  This leaves the question of whether or not to unistall the previous versions of the framework to save some disk space.  For the corporate systems maintainer I would install 1.0, 1.1 and 2.0 on my dev box so that I can work out any bugs that might arise.  On the client computer or recent additions to the office, I would install only the recent version of the framework until I learned that I needed another version.  Since the framework versions can run side by side, there should be no noticible diference to the client.

    Your question earlier as to the compiling of programs targeted at the 1.0 framework, you can do it in #Dev by going to Project--->Project Options--->Configurations---> Either Debug or Release (Depends on what you are doing) and then setting the compiler version.

    Given that you can run 1.0 in 1.1 why would you need to do this?

    Hope this helps.

Page 1 of 1 (8 items)
Powered by Community Server (Commercial Edition), by Telligent Systems
Don't contact us via this (fleischfalle@alphasierrapapa.com) email address.