SharpDevelop Community

Get your problems solved!
Welcome to SharpDevelop Community Sign in | Join | Help
in Search

Existing C# .NetCF program fails to compile using SD 3.1.1.5327 and .NetCF3.5

Last post 03-20-2010 3:30 PM by DanielGrunwald. 4 replies.
Page 1 of 1 (5 items)
Sort Posts: Previous Next
  • 12-22-2009 4:22 PM

    Existing C# .NetCF program fails to compile using SD 3.1.1.5327 and .NetCF3.5

    On my Vista system (64bit) I have installed WIndows SDK for Windows 7, .Net 3.5, .Net 3.5 SP1, .NetCF 3.5, PowerToys for .NetCF 3.5, and SharpDevelop 3.1.1.5327.

    Windows C++ Express 2008  is also installed.

    An existing C# program for my PC compiles using SD 3.1.1.5327 on Vista and runs fine. It was originally delevoped using SD 2.2 and .Net 2.0 on an XP system

    A companion C# program for my WM6 based PDA which also compiled under SharpDevelop 2.2 and .Net 2.0 and .NetCF 2.0 on an XP system gets a compile error on Vista using SharpDevelop 3.1.1.5327 and .Net 3.5, .Net 3.5 SP1, and .NetCf 3.5.

    The error output is:

    Build started.
    Error MSB4018: The "AddHighDPIResource" task failed unexpectedly.
    System.ArgumentNullException: Value cannot be null.
    Parameter name: path1
       at System.IO.Path.Combine(String path1, String path2)
       at Microsoft.CompactFramework.Build.Tasks.Utilities.GetFrameworkSdkBinPathForBinary(String binary)
       at Microsoft.CompactFramework.Build.Tasks.AddHighDPIResource.Execute()
       at Microsoft.Build.BuildEngine.TaskEngine.ExecuteInstantiatedTask(EngineProxy engineProxy, ItemBucket bucket, TaskExecutionMode howToExecuteTask, ITask task, Boolean& taskResult)
    Build failed. (00:00:00.4368000)

    The error is reported on a line in the program but when that line is commented out, the error is still reported on the now commented line.

    The error is always reported on that line and the error is reproducible.

    This exact error has been reported numerous times in the forums but there seem to be no clear or workable solutions all of which I have tried  singally and in combination with no effect.

    If it is a system-wide or SD configuration problem, this error is not the best way of reporting it.

    I am available to provide more information or to test proposed formal solutions.

    Regards,

    Jim

     

     

     

  • 12-22-2009 5:07 PM In reply to

    Re: Existing C# .NetCF program fails to compile using SD 3.1.1.5327 and .NetCF3.5

    What have you tried? Did you try what was suggested in this post?

    The GetFrameworkSdkBinPathForBinary method can fail if the HKLM\Software\Microsoft\VisualStudio\9.0\Setup\VS key exists but there is no ProductDir registry value stored inside that key.

  • 12-22-2009 6:53 PM In reply to

    Re: Existing C# .NetCF program fails to compile using SD 3.1.1.5327 and .NetCF3.5

    After 50 years in this business I must be getting too old to do something as simple as this.

    I had used RegEdit to add the key and values shown in the post to which you refered.  In fact I tried it several times with no luck.

    This time I wrote a little script in AutoIt to add the keys and value, and SD compiled the program just fine.

    After many years being on the receiving end of bug reports and having to deal with erronous ones, I must offer a sincere apology for reporting "a user error" as a bug although I know I have used regedit to do something like this before.

    Please close the incident.

    Regards,

    Jim

     

     

     

  • 03-20-2010 2:46 PM In reply to

    • buli
    • Not Ranked
    • Joined on 03-20-2010
    • Posts 2

    Re: Existing C# .NetCF program fails to compile using SD 3.1.1.5327 and .NetCF3.5

    I also tried RegEdit and it didnt work (simply dont know why). But AutoIt did it perfectly;) Here is the script:

    RegWrite("HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\VisualStudio\9.0\Setup\VS", "ProductDir", "REG_SZ", "c:\Program Files\Microsoft Visual Studio 9.0\")

  • 03-20-2010 3:30 PM In reply to

    Re: Existing C# .NetCF program fails to compile using SD 3.1.1.5327 and .NetCF3.5

    If you're using 64-bit Windows, remember that there are two registries: one for 32-bit programs and one for 64-bit programs.

    regedit edits the 64-bit version by default, but SharpDevelop is a 32-bit program. You'll find the 32-bit portion of the registry in HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node.

Page 1 of 1 (5 items)
Powered by Community Server (Commercial Edition), by Telligent Systems
Don't contact us via this (fleischfalle@alphasierrapapa.com) email address.