SharpDevelop Community

Get your problems solved!
Welcome to SharpDevelop Community Sign in | Join | Help
in Search

Compile error #Develop 4.1

Last post 11-02-2011 8:11 PM by DanielGrunwald. 3 replies.
Page 1 of 1 (4 items)
Sort Posts: Previous Next
  • 11-02-2011 7:16 PM

    • Max
    • Not Ranked
    • Joined on 11-02-2011
    • Posts 6

    Compile error #Develop 4.1

    Hi,

    I just downloaded #Develop 4.1 and following instructions found on wiki page, i got this error:

    C:\SharpDevelop>C:\Windows\microsoft.net\framework\v4.0.30319\msbuild /m SharpDe

    velop.sln /p:Configuration=Debug "/p:Platform=Any CPU"

    Microsoft (R) Build Engine Version 4.0.30319.17020

    [Microsoft .NET Framework, Version 4.0.30319.17020]

    Copyright (C) Microsoft Corporation 2007. All rights reserved.

     

    Build started 02/11/2011 18:54:07.

         1>Project "C:\SharpDevelop\SharpDevelop.sln" on node 1 (default targets).

         1>ValidateSolutionConfiguration:

             Building solution configuration "Debug|Any CPU".

         1>Project "C:\SharpDevelop\SharpDevelop.sln" (1) is building "C:\SharpDeve

           lop\src\Main\ICSharpCode.SharpDevelop.BuildWorker35\ICSharpCode.SharpDev

           elop.BuildWorker35.csproj.metaproj" (2) on node 1 (default targets).

         2>Project "C:\SharpDevelop\src\Main\ICSharpCode.SharpDevelop.BuildWorker35

           \ICSharpCode.SharpDevelop.BuildWorker35.csproj.metaproj" (2) is building

            "C:\SharpDevelop\src\Main\Core\Project\ICSharpCode.Core.csproj" (7) on

           node 3 (default targets).

         7>Project "C:\SharpDevelop\src\Main\Core\Project\ICSharpCode.Core.csproj"

           (7) is building "C:\SharpDevelop\src\Tools\UpdateAssemblyInfo\UpdateAsse

           mblyInfo.csproj" (37) on node 2 (Build target(s)).

        37>EntityDeploy:

             Processing 0 EDMX files.

             Finished processing 0 EDMX files.

        37>C:\Windows\Microsoft.NET\Framework\v3.5\Microsoft.Data.Entity.targets(43

           ,7): error MSB4131: The "EntityDataModelEmbeddedResources" parameter is

           not supported by the "EntityDeploy" task. Verify the parameter exists on

            the task, and it is a gettable public instance property. [C:\SharpDevel

           op\src\Tools\UpdateAssemblyInfo\UpdateAssemblyInfo.csproj]

        37>Done Building Project "C:\SharpDevelop\src\Tools\UpdateAssemblyInfo\Upda

           teAssemblyInfo.csproj" (Build target(s)) -- FAILED.

         7>Done Building Project "C:\SharpDevelop\src\Main\Core\Project\ICSharpCode

           .Core.csproj" (default targets) -- FAILED.

         2>Done Building Project "C:\SharpDevelop\src\Main\ICSharpCode.SharpDevelop

           .BuildWorker35\ICSharpCode.SharpDevelop.BuildWorker35.csproj.metaproj" (

           default targets) -- FAILED.

         1>Done Building Project "C:\SharpDevelop\SharpDevelop.sln" (default target

           s) -- FAILED.

     

    Build FAILED.

     

           "C:\SharpDevelop\SharpDevelop.sln" (default target) (1) ->

           "C:\SharpDevelop\src\Main\ICSharpCode.SharpDevelop.BuildWorker35\ICSharp

           Code.SharpDevelop.BuildWorker35.csproj.metaproj" (default target) (2) ->

           "C:\SharpDevelop\src\Main\Core\Project\ICSharpCode.Core.csproj" (default

            target) (7) ->

           "C:\SharpDevelop\src\Tools\UpdateAssemblyInfo\UpdateAssemblyInfo.csproj"

            (Build target) (37) ->

           (EntityDeploy target) ->

             C:\Windows\Microsoft.NET\Framework\v3.5\Microsoft.Data.Entity.targets(

           43,7): error MSB4131: The "EntityDataModelEmbeddedResources" parameter i

           s not supported by the "EntityDeploy" task. Verify the parameter exists

           on the task, and it is a gettable public instance property. [C:\SharpDev

           elop\src\Tools\UpdateAssemblyInfo\UpdateAssemblyInfo.csproj]

     

        0 Warning(s)

        1 Error(s)

     

    Time Elapsed 00:00:00.88

     

    i also have googled about the error but cannot find a work around.

    Can somebody help me please?

    (i hope to be in correct forum section)

    Max

    Filed under:
  • 11-02-2011 8:05 PM In reply to

    Re: Compile error #Develop 4.1

    Do you have the .NET 4.5 developer preview installed? I believe that's a bug in the preview.

  • 11-02-2011 8:08 PM In reply to

    • Max
    • Not Ranked
    • Joined on 11-02-2011
    • Posts 6

    Re: Compile error #Develop 4.1

    Yes, i have all 3 version of .net 4.5 installed

    • Microsoft .NET Framework 4.5 Client Profile Developer Preview
    • Microsoft .NET Framework 4.5 Developer Preview Multi-Targeting Pack
    • Microsoft .NET Framework 4.5 Extended Developer Preview
    does #Develop 4.1 depend on .Net 4.5?

  • 11-02-2011 8:11 PM In reply to

    Re: Compile error #Develop 4.1

    SharpDevelop 4.1 requires .NET 4.0. It can run on .NET 4.5, but there seems to be a bug in MSBuild 4.5 that causes the build to fail.

Page 1 of 1 (4 items)
Powered by Community Server (Commercial Edition), by Telligent Systems
Don't contact us via this (fleischfalle@alphasierrapapa.com) email address.